Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Typhoon G gimbal pitch control

Joined
Jan 9, 2017
Messages
4
Reaction score
1
Age
64
I recently picked up a Typhoon G (Factory Re-certified) to make use of a GoPro I had and it appears that the pitch control on the gimbal does not function when attached to the quadcopter. The pitch control DOES work on the steady grip, but not on the bird. Where should I look for the problem?
 
Joined
Sep 28, 2015
Messages
411
Reaction score
98
Age
61
Location
Crossville, Tn - East Tennessee
Are you moving the Slider Dial on the left side of the ST10+ Controller? That is what controls the Up and Down.

Make sure that Copter is on a level surface before you turn it on. Is the GoPro in the Gimbal when you tried this on the Copter.
 
Joined
Jan 9, 2017
Messages
4
Reaction score
1
Age
64
Are you moving the Slider Dial on the left side of the ST10+ Controller? That is what controls the Up and Down.
Yes, I operate the slider but it has no effect on the camera pitch. I have also checked the operation of slider with the hardware monitor on the ST10+. The numbers indicate that the slider is moving through the entire range.
 
Joined
Jan 9, 2017
Messages
4
Reaction score
1
Age
64
Strange. Does your Gimbal use a Wire to Connect to the Quad Copter? Or is it using the contacts?
There are contacts (3) on the top of the gimbal that make contact with the Typhoon when it is attached, and there is cable from the gimbal the plugs into a servo-like jack on the aircraft. This cable is also used on the grip when the gimbal is attached.
 
Joined
Sep 28, 2015
Messages
411
Reaction score
98
Age
61
Location
Crossville, Tn - East Tennessee
That is good that you have the Cable that attaches to the Copter/Steadygrip. The Contacts on Top of the Gimbal would not come into play because there most likely are not any contacts on the Copter Mounting Plate nor the SteadyGrip Mounting Plate. That I would think would be a conflict connection. Some of the newer Copters used the contacts exclusively and had no cable. That is why I asked you because the contacts could be a source of your problem.

Here is another thread that people were talking about your exact problem with no apparent solution tho.
Brand new q500 4k, gimbal not working

Have you tried to re-calibrate?

Can you shoot Video while it is attached to the Copter?
 
Joined
Jan 9, 2017
Messages
4
Reaction score
1
Age
64
Another thing to check is to remove the Gimbal in the Transmitter Setup and then Re-Bind it to the Transmitter.

I also found this information about a broken wire. Not specific to Yuneec but does mention a broken wire problem.
CAmera not tilting on new Q500
I found my problem! I was checking the continuity on the connection cable from the gimbal to the copter, and while I had good continuity on all three wires, two of the three contacts in the copter end were not seated in the plug - a little pull on wires and the contacts slid right out of the shell. This was preventing one of them from making contact. FYI, the gimbal works fine on the steady grip WITHOUT the cable connected, and still allows manual pitch control. The power and control signals must be going through the sliding contacts on the steady grip.
 
  • Like
Reactions: spyguy

New Threads

Members online

Forum statistics

Threads
16,653
Messages
194,136
Members
19,329
Latest member
damiano