Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Typhoon G, Video signal loss on every flight

Joined
Aug 3, 2016
Messages
5
Reaction score
0
Age
42
Location
Ontario Canada
I love my Typhoon G, but ever since I purchased it I have had issues with losing video connection. Anything further than about 50 feet away from the controller and I lose the video feed. Anyone have any sugestions on how I could fix this problem. I contacted Yuneec but they wanted me to send the drone and controller to California for service. I am very far away from California and don't feel comfortable sending my new drone that far. Any help will be greatly appreciated.
Cheers
 
Joined
Jul 21, 2016
Messages
14
Reaction score
1
Age
33
i got same issue on my video connection but the reason is i did not push properly the connector from the mk58. after i push it genly and i hear a click the video connection issue is solved.
 
Joined
Oct 11, 2015
Messages
598
Reaction score
273
Age
62
  • Like
Reactions: Tony Camp
Joined
Jul 21, 2016
Messages
14
Reaction score
1
Age
33
First you need the right kind of coax lead that will snap into the MK58.
2x RP-SMA Female to MMCX Male Right Angle RG316 Coaxial Pigtail Cable 6" 15cm

And then you can run what ever clover leaf antenna you want.
I just bought this set as it worked good for me but there are many others out there that claim better performance.
FPV Clover Leaf Omni-Directional Circular Polarized 5.8 GHz Video/Audio Antenna
thanks men...ill try to look for this in our local rc store
 
Joined
Aug 3, 2016
Messages
5
Reaction score
0
Age
42
Location
Ontario Canada
First you need the right kind of coax lead that will snap into the MK58.
2x RP-SMA Female to MMCX Male Right Angle RG316 Coaxial Pigtail Cable 6" 15cm

And then you can run what ever clover leaf antenna you want.
I just bought this set as it worked good for me but there are many others out there that claim better performance.
FPV Clover Leaf Omni-Directional Circular Polarized 5.8 GHz Video/Audio Antenna
Thanks for the info, I just ordered both. Hopefully it works better :) cheers
 
Joined
Oct 11, 2015
Messages
598
Reaction score
273
Age
62
Did you order a RP-SMA Male to SMA Female Right Angle 90-Degree Adapter? If not you can find them on ebay.
 
Joined
Aug 3, 2016
Messages
5
Reaction score
0
Age
42
Location
Ontario Canada
i got same issue on my video connection but the reason is i did not push properly the connector from the mk58. after i push it genly and i hear a click the video connection issue is solved.
I checked and my plug was connected properly. Gonna try a different antena and hope that cures it
 
Joined
Jul 29, 2016
Messages
19
Reaction score
0
Age
48
I am losing connection on every flight as well. It can be only 30 feet away, still disconnects on me
Making me crazy now. Have 4k model, purchased 1 month ago
 
Joined
Jul 21, 2016
Messages
14
Reaction score
1
Age
33
I am losing connection on every flight as well. It can be only 30 feet away, still disconnects on me
Making me crazy now. Have 4k model, purchased 1 month ago
g type antenna can be relocated but i think the 4k dont have external antenna right?
 
Joined
Jul 29, 2016
Messages
19
Reaction score
0
Age
48
g type antenna can be relocated but i think the 4k dont have external antenna right?
Yes it seems to be internal. I can control the camera pitch still, up n down... but still loses connection and video. I have read several things, but wanted to ask here befire I take anything apart, or send it back to be looked at.
Thanks again..
 
Joined
Oct 11, 2015
Messages
598
Reaction score
273
Age
62
Yes it seems to be internal. I can control the camera pitch still, up n down... but still loses connection and video. I have read several things, but wanted to ask here befire I take anything apart, or send it back to be looked at.
Thanks again..
On one of the other forums there was a discussion about this problem, one member talked to a tech from Yuneec and this tech guy said anytime you update firmware your suppose to delete your bind to the Q and start over. None of us ever heard of this but what the heck it was worth a try. I did seem to solve most everyone's video disconnects. If you want give this a try.

Turn Everything Off Bird and TX

Turn on the ST10+ but not the bird

After it initializes select Model. Select it at the bottom right of screen.

Touch and Hold the model. Menu appears. Touch & DELETE.

Now turn off ST10+

Turn on the Bird. After it is on, Tilt forward from the back end 45 degrees two times to enter Bind Mode. Back light will start flashing Orange.

Turn on ST10+ Select Flight Settings,at this time it will ask you to go to model select and create a new model. Once you have giving it a name click save and then Select Bind. Bind the Model and Bind the Camera

Tap Return Button at bottom of ST10+ a few times to get back to main screen. You should now see the camera come up on display.
 
Joined
Jan 30, 2017
Messages
2
Reaction score
0
Age
66
Yes it seems to be internal. I can control the camera pitch still, up n down... but still loses connection and video. I have read several things, but wanted to ask here befire I take anything apart, or send it back to be looked at.
Thanks again..
I have recently experienced a similar problem with my Q500 4K. I discovered flying over a building will completely wipe out the signal, or over anything metallic, like a bridge. The signal goes completely away and I have no idea what the drone is doing. Scary. Don't know if buying a better antenna system will help, but it's worth a try.
 
Joined
Feb 8, 2016
Messages
34
Reaction score
9
Location
Texas
I've battled this problem since day 1 with my Q5004k. I'm not sure there is a 100% fix. I have installed an Itelite external antenna on my ST10 and an external antenna on my Cgo3. I still lose signal, only not as bad. As a matter of fact if I had it to do over I don't know if I'd do either of these mods. In talking to a tech with a dealer and doing my own research I have decided that the 5.8 ghz signal that the video works on is just real susceptible to interference. Whether from other signals or objects it is easily interrupted. I have been out 5000 ft. at 125 ft. altitude and back with no loss. Then at the same place loss the camera at 500 feet away. Right now I've just accepted it. But I'm also thinking very serious about selling/trading my Q500 and going another route.
 

New Threads

Forum statistics

Threads
16,800
Messages
196,035
Members
19,489
Latest member
tmhicks