Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

CGO3 camera SD card problems

Joined
Jan 11, 2016
Messages
12
Reaction score
2
Age
39
I just recently bought a Yuneec Typhoon Q500 4K and I'm having problems with the CGO3 camera.

The cameras SD-card slot has these problems:
- Sometimes the SD card is not detected at all
- Sometimes it detects the card, but doesn't write anything to it (even if the GUI on the ST10+ remote indicates it's recording!)
- Sometimes it records a file, but the file is corrupt

Fair to say, the SD-card slot (or something related to it) is somehow broken. All the footage I've managed to get out of the thing when connected to the SteadyGrip have these "hickups" in them, and I have not once had a usable video file when the camera is connected to the Q500.

I've tried 2 different cards with the camera; The 16GB Panasonic card that came with the Q500 and a 32GB Sandisk Ultra card.

Any advice? I thought I'd try a contact cleaner in the SD-card slot, but I doubt that'll work...
 

BEE

Joined
Nov 15, 2015
Messages
56
Reaction score
10
Age
53
All i can say is try a class 10 or better sd card and format in fat32.......or it could just be a faulty cgo....
I personally wouldnt spray anything into the card slot
 
Joined
Jan 11, 2016
Messages
12
Reaction score
2
Age
39
The spray i'm going to use is a contact cleaner specifically designed for electronics cleaning. Not like I'm going to spray it with Ajax or something ;)
 
Joined
Dec 5, 2015
Messages
17
Reaction score
0
Age
77
Location
Chino Valley, Arizona
As stated above, spraying contact cleaner into the card slot is NOT recommended. There are components/wires/materials inside the camera which could be adversely affected by the spray.

I recommend that you take a piece of cardboard the thickness of an SD card, saturate it with denatured alcohol (I use Everclear available at most liquor stores) and insert it into the slot several times to clean the contacts.

RodeoGeorge
 
Joined
Jan 11, 2016
Messages
12
Reaction score
2
Age
39
I cleaned the slot, and it did get better. However, not enough better. Indoors it recorded files with a few video glitches, but as soon as I went outside to fly, it wouldn't work. I was able to take a few JPGs and start the recording, but it failed right after the camera buffer (i believe) run out. It's -7°C at the moment, but that's nothing the camera couldn't handle. Everything else works just fine, it just doesn't record files.
 
Joined
Jan 11, 2016
Messages
12
Reaction score
2
Age
39
Upon closer inspection of the files recorded while I tested the camera. The glitches are still there....

Screen Shot 2016-01-11 at 19.10.03 copy.jpg

I know I'm not alone with this, because 2 other people (I have found on the forums) have had these same kind of symptoms.
Oh well.. time to send it for servicing. Maybe it's cold solder somewhere, that makes even worse contact in the cold or something?
 
Joined
Sep 10, 2015
Messages
23
Reaction score
2
Age
56
Yeah, that looks horrible. Keep us posted on the resolution. I've not experienced that in the least. Sorry that you have. Best of luck.
 
Joined
Jan 11, 2016
Messages
12
Reaction score
2
Age
39
Problem solved, the reseller gave me a completely new Q500 4K. :) Now everything works as it should!
 
Joined
Sep 10, 2015
Messages
23
Reaction score
2
Age
56
BAM!.... There you go. Glad it's working as it's meant to be. Happy Flying!
 

BEE

Joined
Nov 15, 2015
Messages
56
Reaction score
10
Age
53
Great news !!! Now go take some awesome 4k photos/videos of your frozen landscape ..:eek::)
BTW who was the seller that did the right thing ?
 
Joined
Dec 19, 2015
Messages
30
Reaction score
5
Age
49
The spray i'm going to use is a contact cleaner specifically designed for electronics cleaning. Not like I'm going to spray it with Ajax or something ;)
I can't stop laughing about you saying "Not like I am going to spray it with Ajax or something" that just made me laugh for some reason. How do you know Ajax wouldn't work until you try it. LOL LOL Please don't use Ajax!!!
 
  • Like
Reactions: John K. Fitzgerald
Joined
Mar 16, 2016
Messages
2
Reaction score
1
Age
45
I bought this morning q500 4k. I have several self made multis but none of them offer enough stabile video at the moment. The idea was to do some aerial shoots from a special happening today without any fuzz and pile of cables, screwdivers etc.
I experienced exactly similar behaviour from my brand new 4k as yours! The result of tens of flights, settings, formatting, testing, flying again was total zero usable videos. Usually the connection between controller and camera just cut off and video file was corrupted. Or, video corrupted otherwise. Or file size was zero. I used included SD card after formatting. So frustrating.
Interesting, that I bought this from Kyosho shop Jumbo, Vantaa, Finland which is the importer in the country. Maybe they had bad batch or I got your old one, Tommiph :) . However, I will go tomorrow to ask if they have spare one for me, too...
 
Joined
Mar 16, 2016
Messages
2
Reaction score
1
Age
45
Hi, I just got new camera unit from dealer. All problems seems to be disappeared. I am very glad the customer service works with Yuneec!
 
  • Like
Reactions: Daniel O
Joined
Mar 9, 2016
Messages
22
Reaction score
6
Age
52
i just got the 4k and am having the same problem, camera wont recognize the SD card. I'm calling Yuneec support tomorrow to see what they say. I also have a problem with the battery door wont latch. :-(
 
Joined
Jan 5, 2017
Messages
25
Reaction score
11
Age
51
Location
Wisconsin
I have had the same issue. Mine always detects the SD card, and puts video files on the card, but when you play them in a video viewer like Real Player, only half of them will play. The other half will say they are corrupt and not play. I've tried other SD cards and video players. I've taken some good scenery vids that can't be sesn.
 

New Threads

Members online

Forum statistics

Threads
16,973
Messages
198,190
Members
19,640
Latest member
mary