Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Firmware Issues / Breeze WiFi fix / Tips

Joined
Feb 27, 2019
Messages
1
Reaction score
0
Age
62
Big problem with the Breeze currently ...

Was using the Breeze successfully for a while - I had purchased from the U.S.A., but updated firmware to Oeceania 1.37 version (I'm in Australia), but about a month ago the unit automatically updated itself to 1.47, which I assume is a U.S. firmware. The wifi connects, but the telemetry doesn't, and if I try to calibrate, I get a "batteries below 20%, can't calibrate" message. I have checked the batteries with a multimeter, they are fine. I have attempted to downgrade the firmware using the uncompressed "bin" method, but then the android app tells me "you have the latest firmware, no need to upgrade". I believe a hard reset does not change the firmware. What do I do now? The unit is a brick until I can get the firmware back to 1.37

Thank you,

Doric
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,425
Reaction score
3,697
Location
Genesee, MI USA
Skibug

When you are connected go to About in Settings and report your FC, ESC, and Camera versions and include the letter in the camera version (it reports the region of the firmware - A for Americas, F for Europe, and K for Asia and Pacific).

With the symptoms you describe try putting your phone in airplane mode, then enable WiFi and connect to the Breeze, then open Breeze Cam and see if you get full connectivity (you’ll see battery percentage and status icons will not be gray).
 

New Threads

Members online

Forum statistics

Threads
19,769
Messages
228,863
Members
23,729
Latest member
DreDay