Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Post your results of the 11-16-2016 firmware here.

Tell us about your experience with this update.

  • I have installed the 11/16/2016 firmware.

    Votes: 125 74.4%
  • I used the auto update using the ST16 menu.

    Votes: 53 31.5%
  • I have flown following the update and everything seems to work as expected.

    Votes: 82 48.8%
  • After updating I have a new problem.

    Votes: 43 25.6%
  • The landing seems to have improved with this update.

    Votes: 21 12.5%
  • I like the new accelerometer calibration.

    Votes: 21 12.5%
  • I have tried the new muti ST16 connection to the camera.

    Votes: 9 5.4%
  • I don't plan to install this update.

    Votes: 11 6.5%
  • It bricked my H

    Votes: 18 10.7%

  • Total voters
    168
R

Rayray

Guest
I updated two TH's with this new firmware today, using only the micro-card method. All went smoothly, as usual you have to rebind after the ST16 update and before the Craft update. New model is necessary in some cases.

As per the instructions, I did an Accelerometer calibration after each craft upgrade. I then flew each craft some 10 minutes in Angle mode, this went smoothly. I'll continue to test the new upgrade over the next couple of days, looking closely at GPS, Accelerometer, and compass co-ordination.

Update- 11-17-16 Flew both craft more this morning, GPS acquisition and stability seems improved, Movement above ground at landing smoother, less twitchy. Since I'm flying at my usual "airport", I did not re-cal the compass or gimbal, Compass is fine on both craft.
 
Last edited by a moderator:
  • Like
Reactions: donmcw
Joined
Jun 9, 2016
Messages
1,480
Reaction score
1,298
Age
49
Location
UK
By all accounts this is a 'bug fix' release after the last big firmware upgrade. Yuneec are happy that this improves the flight characteristics and addresses a number of other small gotchas.

I've not flown long on it, but it seems good. Switched between panorama and video and back again, took pictures in some challenging conditions (high contrast, early morning sunrise) and got some lovely results:

Waterbeach River View

Very satisfied!
 
Joined
Sep 10, 2016
Messages
5
Reaction score
2
Age
33
Updated today, cleared flight mode data, calibrated all, tested, all ok.
 
Joined
Jan 19, 2016
Messages
384
Reaction score
122
Age
58
Location
USA
Massive FAIL for me using the auto-update. During the update the lights went out on the H, the only light was on the CGO... waited, waited, waited, waited... Let it sit for a half hour, nothing.... Power cycled the ST-16, nothing.... Attempted to power cycle the H, nothing...

The only light on is the camera light and the main power switch otherwise no main status light or lights on the arms....

I've done every firmware upgrade with ZERO issues prior to this.. Looks like my H is bricked.....

How about adding a new option; "My H is Bricked".... :(
 
Last edited:
Joined
Jun 9, 2016
Messages
1,480
Reaction score
1,298
Age
49
Location
UK
Massive FAIL for me using the auto-update. During the update the lights went out on the H, the only light was on the CGO... waited, waited, waited, waited... Let it sit for a half hour, nothing.... Power cycled the ST-16, nothing.... Attempted to power cycle the H, nothing...

The only light on is the camera light and the main power switch otherwise no main status light or lights on the arms....

I've done every firmware upgrade with ZERO issues prior to this.. Looks like my H is bricked.....
That can be rescued with the Windows GUI. Get a copy of the 1.28 (?) FC software and install it directly on the H to get it to recover. You can download the file from the firmware archive (check the post on this forum). Then with the H unplugged and with no battery, start the windows GUI. Start the firmware updater in the GUI and load the FC software you downloaded. Then, plug the H into the PC and it will install the firmware. Once it's done, unplug everything, put in the battery and your H should start up again.
 
Joined
Jan 19, 2016
Messages
384
Reaction score
122
Age
58
Location
USA
Thanks! Does the work with Apple Computers? I don't own a Windows computer...

That can be rescued with the Windows GUI. Get a copy of the 1.28 (?) FC software and install it directly on the H to get it to recover. You can download the file from the firmware archive (check the post on this forum). Then with the H unplugged and with no battery, start the windows GUI. Start the firmware updater in the GUI and load the FC software you downloaded. Then, plug the H into the PC and it will install the firmware. Once it's done, unplug everything, put in the battery and your H should start up again.
 
Joined
Aug 19, 2016
Messages
674
Reaction score
321
Age
54
Location
Muskegon, MI
Thanks! Does the work with Apple Computers? I don't own a Windows computer...
Unfortunately no, unless you use a virtual machine like VMWare Fusion or VirtualBox, but you would still need a Windows License. FYI - I've had minimal success using Wine Bottler. Given the sensitive nature of your issue I wouldn't mess around with a VM on a Mac. Just see if you know someone with a Windows machine which they may let you borrow for an hour.
 
Joined
Apr 27, 2016
Messages
170
Reaction score
49
Age
77
The GUI works fine on my Mac Book Air in the Bootcamp partition using Windows 7.
 
Joined
Nov 3, 2016
Messages
2
Reaction score
2
Age
70
My updates went very smoothly today. Re-calibrated as necessary and had a short flight between the sleet showers. It seemed to fly OK and was stable although I lost the camera connection at 200 feet. This loss of connection was very prevalent since the last update and I had hoped it would now be behind me!
 
Joined
May 12, 2016
Messages
300
Reaction score
22
Age
46
It is premature to say that everything is good, but after updates and calibrations I made one flight and everything went well. Only thing is that I lost video feed when legs went up.
Just to say that there was and H was very stable.
Anyway I will not vote on anything up there just yet as I need to made several more flights to be sure that maybe toilet bowl and drifting is gone.
 
  • Like
Reactions: Unlocktender
Joined
Apr 24, 2016
Messages
495
Reaction score
201
Did the update today without any issues.

Did all the calibrations and went for a flight.

Immediately got compass errors AGAIN that were fixed with the last firmware.
With no input on the sticks was getting motor surging and twitching and the H was bouncing all over the place.
Was able to get it landed and will try the calibrations over again.

So sad because it was flying great on the last firmware, it just had a little drifting but nothing serious.
 
Joined
May 11, 2016
Messages
567
Reaction score
194
Age
71
Location
Cardiff-Wales UK
Just upgraded with cards and all went smoothly according to ST16 dialogue box, will hopefully test with H in the morning if rain desists.
 
Joined
Jan 19, 2016
Messages
384
Reaction score
122
Age
58
Location
USA
UPDATE!

Typhoon H is "unbricked"! Thanks to all that helped! Had to dust off and power up my old Windows box "hoping" it would still work. After some updates to it, I was able to load the GUI and load the FC V1.28 version. The H booted up on it!

Rather than jump to the 3.01 Version I started with the 3.0 version. Every upgrade took! I did all the calibrations and am now waiting for some nice weather as we currently have snow and blowing snow.

Apparently before the loss of connection the camera did update. I did have to rebind but I notice I had to follow a specific sequence other than the standard rebind sequence to get my camera bound. The normal "bind" sequence did not have the camera show up even hitting the "refresh". I had to go back and select the "model" then on the bind screen I had to select my CGO model, only then did it show up when I did refresh.

Hopefully when I fly it, everything will be fine!
 
Joined
Jul 23, 2016
Messages
31
Reaction score
4
Age
45
Updated no problems via the ST16

Just need a compass calibration and ready to go

One thing I did notice is my Roll stick was doing strange things in the hardware monitor. No matter what I do in calibrations I cant get it centred. I kept playing with it - as if to wear it in - and its behaving a bit better. For a while there it wasn't even giving me access to the full stick movement. I am thinking this was causing the drifting issues to the left for me as at the beginning of a flight it would be fine and towards the end it would be drifting - which seems the roll axis was sticking. Hopefully ok now or I will have to have the ST16 serviced...
 
  • Like
Reactions: yerrickl

New Threads

Forum statistics

Threads
16,816
Messages
196,286
Members
19,512
Latest member
italian pilot