Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

ST16 Battery Charging Issue

Joined
Jul 28, 2018
Messages
23
Reaction score
9
Age
29
Hi guys,

Just unboxed my Typhoon H today, but have been doing hours of reading and YouTube browsing to prepare for its arrival. To preface the meat & potatoes of this post, I've searched around to see if anything else on the forum matches my question, but it's only bits and pieces of the issue at hand, so here's the rundown of when I went to get everything charged up, and the issue:

Using the stock charger, I plugged the charger in and got the green blinking light, at this point I dropped the crafts battery in for a charge, and it began to charge, indicated by the red blinking light. Good there!

I plugged in the provided USB to the battery charger, and connected it to the ST16. At this point, the fans kicked on for a brief second, and the screen went to a dull dark blue. To see battery status, I tapped the screen to no avail.

Confused, I unplugged, and turned the st16 on to check current battery status from the factory, that way even if I cant view while charging, i'll have a baseline for when I let it sit and charge for a bit. It looked like 86% was what was left from the factory. At this point, i shut the ST16 down and reattached the charger to see if I can get lucky. After 2 hours pass, and my crafts battery is now fully charged...I turn the ST16 on, nothing, in fact..the battery is now at 83%.

First instinct was to try a different charging source (straight into the wall rather than through the charging station) so I have done that, but immediately I noticed there was still no charge status when tapping the screen. I also plan on trying a different cable.

The real question is, if the ST16 was at 86% out of the box, it has obviously been charged recently during the QC process, but now somehow, magically, will not charge for me.

Any tips, or similar issues that you guys have experienced? My next step is obviously contacting Yuneec for troubleshooting, but want to cover all bases first. I just cant wait to get this bird in the air!
 
Joined
Jul 28, 2018
Messages
23
Reaction score
9
Age
29
It's also worth mentioning that I did try disconnecting the battery itself, booting back up, powering down, then reconnecting - with no luck.
 
Joined
Jun 20, 2018
Messages
406
Reaction score
261
Location
Cleveland TN
Leave the st16 switched off.
When the USB is plugged in, you should briefly see the Yuneec splash.
That confirms the USB voltage is OK.
It takes almost 30 seconds to get into charge monitor mode.
After that a screen tap should show the charge status.
If no charge status shows by then, the ST16 software has a problem.
(My st16 took 9 hours to charge the first time.)
As soon as I got it going, I made an image backup of the entire ST16 to my PC.
 
  • Like
Reactions: Jhen19
Joined
Jul 28, 2018
Messages
23
Reaction score
9
Age
29
Leave the st16 switched off.
When the USB is plugged in, you should briefly see the Yuneec splash.
That confirms the USB voltage is OK.
It takes almost 30 seconds to get into charge monitor mode.
After that a screen tap should show the charge status.
If no charge status shows by then, the ST16 software has a problem.
(My st16 took 9 hours to charge the first time.)
As soon as I got it going, I made an image backup of the entire ST16 to my PC.

With all of this being said, I think most of your reply were things that i did ensure doing, and noted in my original post, they simply just did not work. But you do make me wonder, could this be a firmware issue?,
 
Joined
Jul 28, 2018
Messages
23
Reaction score
9
Age
29
With all of this being said, I think most of your reply were things that i did ensure doing, and noted in my original post, they simply just did not work. But you do make me wonder, could this be a firmware issue?,
Update: I once again disconnected the battery and then initiated the charge. I wiggled the connector around just a bit and viola! It began to charge, and I could see battery status! Looks like I'll be contacting Yuneec about the charging port!
 
Joined
Jul 4, 2017
Messages
4,240
Reaction score
2,002
I use my android phone charge never any issues, been doing this for over a year. Also charge my st 16 in my vehicle using the same method. Much much faster.:)
 
  • Like
Reactions: Jhen19

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
8,116
Reaction score
4,580
Location
Bessemer, MI
Update: I once again disconnected the battery and then initiated the charge. I wiggled the connector around just a bit and viola! It began to charge, and I could see battery status! Looks like I'll be contacting Yuneec about the charging port!
It does appear the USB port on the ST16 may not be connecting properly. Try using the online live chat to contact Yuneec. Mornings work best.
 

CraigCam

Premium Pilot
Joined
Oct 1, 2016
Messages
1,520
Reaction score
663
Age
62
That USB input can be an issue. I’ve got one that needs a firm seating to get charging. The provided USB cable has always worked for me and I try to always use it. The provided charger is not the best for long term battery life over numerous charge cycles. Do you own another RC charger? I love my Hi Tec II. I got EC2 leads and charge my ST battery using proper LIOn settings then top off via USB if I run a battery below 60%.
 

PatR

Premium Pilot
Joined
May 1, 2016
Messages
10,804
Reaction score
6,315
Location
N. California
But you do make me wonder, could this be a firmware issue?,

Absolutely not. Do not mess around with the firmware until well after you understand the system. There are zero “bad” firmware versions.
 
Joined
Jul 28, 2018
Messages
23
Reaction score
9
Age
29
Absolutely not. Do not mess around with the firmware until well after you understand the system. There are zero “bad” firmware versions.
Appreciated, however I determined it was the USB input port :)
 

New Threads

Members online

No members online now.

Forum statistics

Threads
19,901
Messages
230,078
Members
24,062
Latest member
smoke2cuffs