Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

ST 16 shuts off after first Yuneec logo

Joined
Dec 3, 2020
Messages
19
Reaction score
2
Age
26
Hi There,

Having trouble with my controller. It will just shut down after the first "Yuneek" logo. Tried the sd card with the update.zip and the Yuneec-App-Release.apk to no avail. I have mashed the centre button when it starts and that didnt work either.

Any suggestions?
 

h-elsner

Premium Pilot
Joined
Mar 23, 2016
Messages
1,327
Reaction score
967
Location
Bavaria / Germany
The first idea that comes in my mind is the battery. Maybe the voltage goes rapidly down when processor starts to work.
Is the loading icon present when you connect the loader with the USB?

br HE
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,443
Reaction score
3,721
Location
Genesee, MI USA
I havent been connecting anything with a USB. Should I be?
How do you charge the battery if you don’t charge through the USB port?
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,443
Reaction score
3,721
Location
Genesee, MI USA
So with a full charge on the ST16 you get the first Yuneec logo when you power on then it goes blank. Do I understand you correctly?
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,443
Reaction score
3,721
Location
Genesee, MI USA
I don’t have any personal experience with this. Take a look at this thread H520 ST16 Controller Update seems to have KILLED my ST16. HELP!.

Power on the ST 16 and start tapping the center soft key at the bottom of the screen repeatedly. It should get you to a menu where you can select a reboot option.

Mine is not stuck in a loop and doesn’t respond to this procedure so I don’t even know what items appear on the Fastboot menu. When @Steve Carr or @WTFDproject they may be able to guide you further. There is another member @SilentR9 that is good at restoring bricked ST16’s.
 
  • Like
Reactions: Steve Carr

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
2,765
Reaction score
2,116
Location
North Carolina Piedmont, USA
Taking it one step at a time, it seems to be important both how and when you use the center button.
First part is HOW. You don't just press and hold. You have to tap it repeatedly. And it sees to be some magic tap rate somewhere between too slow and too fast. (I never actually had to do it either, so I can't give much help as to "how fast".
Second part is WHEN. The consensus seems to be that you start as soon as you power on the controller, and keep tapping even after the screen goes dark. I also don't have any basis for "how long" is reasonable, so just give it enough time to be convinced it is going to work. Then start again with a little different tap rate and see what happens.

If it actually works, it would be good to know about how fast and how long you did the tapping.
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,443
Reaction score
3,721
Location
Genesee, MI USA
I was informed that the procedure I linked you to for the ST16S may not work with the ST16 (for the H480). Most likely the reason I could not get the Fastboot menu to appear on mine when I tried it. Hopefully @SilentR9 will notice your post and be able to help.
 
  • Like
Reactions: IanWalker
Joined
Dec 3, 2020
Messages
19
Reaction score
2
Age
26
I did at one point get the fast tab to succeed, but it just went into an update, shut off, and im back at the same place. I have tried the fast tap again many times, but i will keep trying. Maybe I had the perfect speed the time it worked?
 
  • Love
Reactions: Mike Irish

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,443
Reaction score
3,721
Location
Genesee, MI USA
Did this happen just out of the blue or were you in the process of updating firmware?
 
  • Like
Reactions: WTFDproject

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,443
Reaction score
3,721
Location
Genesee, MI USA
Do you recall what firmware revision you were updating from and to? What instructions were you following?
 

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
8,085
Reaction score
4,553
Location
Bessemer, MI
Unfortunately I wasnt the one doing the update. My boss was and he has no idea :\
Download the 3 files from this link: ST16_V3.1.30
Copy them to an sd card which is formatted as FAT32.
Insert the sd card in the controller and then turn it on. Wait to see if it starts updating.

Do not unzip any of the files.
 
  • Like
Reactions: Mike Irish
Joined
Dec 3, 2020
Messages
19
Reaction score
2
Age
26
Should I have the three files in the folder ST16_V3.130, or three directly in the card?

And should I hit the middle button while it opens, or just turn it on and leave it?
 

New Threads

Members online

Forum statistics

Threads
19,790
Messages
229,008
Members
23,761
Latest member
Brick